FLARManager v1.0.1 – Augmented Reality with Flash

Minor update to FLARManager v1.0. Imagination has requested that I not distribute their libraries, so I’ve removed them from the FLARManager distro. This will make it easier for us to ensure both FLARManager and the flare* products are as up-to-date as possible, as well as smoothing out some other potential distribution issues.

However, this means that getting flare*tracker and flare*NFT projects running requires a bit more work. As such, I’ve reverted the examples and tutorials to use FLARToolkit, which I can distribute along with FLARManager, and also created this page to describe, in-depth, how to implement the various tracking engines that FLARManager supports.

Please take a moment to download the latest version of FLARManager and the current evaluation SDKs for flare*tracker and flare*NFT to ensure you’re up-to-date. And feel free to pester me with questions (as comments, below) about setting up your projects — I need your help to get the documentation as clear as possible.

1 Tweet

24 Comments

  1. Thangaraj says:

    Hi Eric,

    Thank you very much for your update. all the samples are working fine. Except “FLARManagerTutorial_Collada.as”. it returns only white screen. i try to load dae from the the file “FLARManagerExample_PV3D.as”, it aslo returns white screen without any compile errors…

    Thanks

  2. Ellis says:

    thanks for ur shared^^

    when i run the FLARManager_AppLauncher.as on flash developer

    there’s a error appeared!

    Error: Embed is only supported on classes and member variables.

    how can i fix it??

    Thanks

  3. ericsoco says:

    @ellis — not sure why the Embed metatag is giving you trouble with FlashDevelop. it’s not a problem with Flash Builder. try googling the problem?

  4. Dwayne says:

    if i publish your code i see that whatever i want to happen when the marker is recognized, happens without the marker being there… which si kinda freaky.. any ideas has to why that is?

  5. Dwayne says:

    sorry if my last comment was confusing. i was in transit. here is the link in question http://www.massideation.com/ar/..

    video is supposed to play when the marker is recognized.. not before..
    any suggestions.

  6. idkwtf says:

    Hi, does anyone know how to use it with Flash Professional? Thanks

  7. ericsoco says:

    @idkwtf — just create a new Document Class that points to or instantiates FLARManagerExampleLauncher.as.

  8. idkwtf says:

    ok, will try. thanks for reply

  9. Dwayne says:

    I set the confidence level to be higher, that seemed to have fixed the issue… eric, does that make sense

  10. ericsoco says:

    @dwayne — glad that worked for you. not sure what would have caused your problem, perhaps something in the background that looks vaguely like a marker. increasing the confidence value would solve that issue.

  11. grahf says:

    Hello, I have tried for many demos your libraries and they are great, but now someone asked tod something diferent, I need to objects appear in the screen but without the marker, only by random chance (you know, like of ghosts appeared in the webcam at random) but I got stock in the moment I need to create a FlarMarker from it’s contructor to add it in the loop function. Do you have an example of how to create a marker object from scratch that shows in the middle of the screen?? Because I can’t find any example

  12. ericsoco says:

    @grahf — no, i don’t have an example of this. but you could dump the transform matrix values of a marker held in front of the screen, wherever you want your “ghost” marker to appear, and then apply those values to your model in the same way a marker’s transform matrix values are normally applied.

    make sense?

  13. Lynda Ray says:

    Hey Eric, great work.
    I am trying to implement the collusion detection between multiple object using your Flarmanger. Can you help me with that.
    Thanks in advance.

  14. Dan says:

    Hi,

    I just wanted to ask you how can I implement this to a website as it works on my machine but when I upload it to a webserver it says movie not loaded but if I go to the direct link of where the .swf is then it ask for permission to access the webcam but once you give permission it just gives a black screen. Do you know why?

  15. siralvarez says:

    I just wanted to do something like this url http://www.youtube.com/watch?v=Az68-AaeMBY

    Can you help me, I’m sorry if this is a stupid question but I’m newer in this.

    Thank you in advance.

  16. Hey Eric, I just updated FlarToolkit, FlarManager, and the jp.nyatla libraries this morning and have been getting all kinds of crazy errors. Deleted everything and pulled fresh libraries, and am down to getting:
    FLARToolkitManager.as, Line 101:
    1178: Attempted access of inaccessible property AR_AREA_MIN through a reference with static type Class.
    FLARToolkitManager.as, Line 101:
    1178: Attempted access of inaccessible property AR_AREA_MIN through a reference with static type Class.
    FLARToolkitManager.as, Line 102:
    1178: Attempted access of inaccessible property AR_AREA_MAX through a reference with static type Class.
    FLARToolkitManager.as, Line 102:
    1178: Attempted access of inaccessible property AR_AREA_MAX through a reference with static type Class.

    Am I doing something wrong?

  17. ericsoco says:

    there were some issues with a CS4 bug that prevented people from compiling. looks like the libspark folks changed things to address that that broke FLARManager. very simple to fix; i can’t do it now but in the meantime, in FLARToolkitManager.as, just replace AR_AREA_MIN with 70 and AR_AREA_MAX with 100000.

  18. Yep that did the trick for that problem… have had a few more errors, mostly dealing with syntax changes, and I think I’ve addressed everything for the most part.. but now I seem to be consistantly getting:

    [FLARManager] Initing camera ‘Microsoft LifeCam VX-6000′.
    [FLARManager] Initial camera validation complete…
    Error: Error #2032: Stream Error. URL: file:///S|/Projects/Internal/ProvingGround/ImageBurst/
    at com.transmote.flar.tracker::FLARToolkitManager/onCameraParamsLoadError()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at flash.net::URLLoader/onComplete()
    [FLARManager] Secondary camera validation failed for camera ‘Microsoft LifeCam VX-6000′. Reiniting camera.
    Error #2044: Unhandled error:. text=Camera not found. Please check your connections and ensure that your camera is not in use by another application.

    Don’t expect you to troubleshoot it for me, but if you have a starting point for what the problem could be, I would definately appreciate it. :P

  19. ericsoco says:

    @michael — were you having the camera issue before you updated flartoolkit? flarmanager is entirely responsible for setting up the camera, so it’s very unlikely that updating alone could have caused the problem.

    maybe a better question is: have you successfully used this camera with FLARManager in the past?

    it is possible that some change in how flartoolkit is getting inited could impact the camera initialization. if all else fails, you could try commenting out the secondary camera validation (just comment out everything within FLARCameraSource.onSecondaryCameraValidation after ‘this.update()’).

  20. Yeah, this same project was working fine before I started updating everything. I can’t say I had success with this camera, though, because I had to change it from FLARCamera3D to FLARCamera_Away3D (the other doesn’t exist anymore) and pass the FLARManager to it as a parameter. Before I had just created the camera and then used .setParam to pass the flar manager’s .cameraParams. Not seeing that as an option with this new camera, so I assume with passing the entire manager to it, it knows how to retrieve the cameraParams?

  21. Guillo says:

    hi im new in this and i cant make my camera to show it keeps giving me this message
    TypeError: Error #1009: Cannot access a property or method of a null object reference.
    at gamut/initFLAR()[/Users/Guillo/Documents/Adobe Flash Builder 4/gamut/src/gamut.as:19]
    at gamut()[/Users/Guillo/Documents/Adobe Flash Builder 4/gamut/src/gamut.as:15]

    it freezes my browser and nothing shows
    any suggestions??

  22. Ashish says:

    Hi Michael,
    I am also facing the same problem.Did you able to figure the reason for that and what is the solution for it???

  23. Ashish says:

    Hi Eric,

    I am getting the following error .Could you please help me out figuring the reason behind it and what could be the right solution ??

    Error: Error #2032: Stream Error. URL: file:///C|/Documents%20and%20Settings/sharmaas/Adobe%20Flash%20Builder%204/FLARTest/bin%2Ddebug/
    at com.transmote.flar.tracker::FLARToolkitManager/onCameraParamsLoadError()[C:\Documents and Settings\sharmaas\Desktop\AR\Actionscripts\com\transmote\flar\tracker\FLARToolkitManager.as:343]
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at flash.net::URLLoader/onComplete()

Leave a Reply

Additional comments powered by BackType